Partial Outage due to our Global Network Provider: Productboard users might experience timeouts
Incident Report for Productboard
Resolved
This incident has been resolved. Thank you for your patience.
Posted Jun 21, 2022 - 08:12 UTC
Update
The issue has been resolved, but we are monitoring the situation. Thanks for your understanding.
Posted Jun 21, 2022 - 07:31 UTC
Monitoring
We have mitigated the incident, and it should now be possible to access Productboard. Please know the mitigation change might need a few minutes to be effective.
Posted Jun 21, 2022 - 07:16 UTC
Investigating
We are currently experiencing a partial disruption of service caused by an issue with our global network provider. Some users might experience timeouts while opening Productboard. We apologize for the inconvenience.
Posted Jun 21, 2022 - 06:56 UTC
This incident affected: Web application.