Delay in processing updates for the notes
Incident Report for productboard
Resolved
This issue has been resolved. Thanks for your understanding and sorry for the inconvenience!
Posted Apr 29, 2020 - 14:36 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 29, 2020 - 14:17 UTC
Identified
We are experiencing a big delay in processing updates notes related.

We are working on a fix and will update you as soon as possible. Sorry for the inconvenience!
Posted Apr 29, 2020 - 14:06 UTC