Payment processing disruption

Incident Report for Productboard

Resolved

This incident has been resolved.
Posted Mar 02, 2026 - 13:21 UTC

Investigating

We're aware of an issue affecting subscription purchases and updates. This is caused by an ongoing incident at our payment provider. We are monitoring the situation and services will be restored once the upstream issue is resolved.
Posted Mar 02, 2026 - 10:38 UTC