Documents don't load

Incident Report for Productboard

Resolved

This incident has been resolved.
Posted Mar 03, 2026 - 17:42 UTC

Monitoring

The issue has been mitigated and Documents can be loaded again. We're currently monitoring it.
Posted Mar 03, 2026 - 16:39 UTC

Investigating

We are experiencing issues with loading documents. You may experience slow loading times or it might not load at all. We're investigating the issue.
Posted Mar 03, 2026 - 16:23 UTC
This incident affected: Web application (Boards and data).