Productboard components may not load

Incident Report for Productboard

Resolved

The incident has been fully resolved
Posted Mar 02, 2026 - 13:53 UTC

Monitoring

The issue has been identified and mitigated. We're monitoring it now.
Posted Mar 02, 2026 - 12:43 UTC

Investigating

We're currently experiencing issues that may result in some components not loading for you such as new boards or sidebars. It's currently being investigated.
Posted Mar 02, 2026 - 12:37 UTC
This incident affected: Web application (Boards and data, Teamspaces).