Connection Issues
Incident Report for Productboard
Resolved
This incident has been resolved.
Posted Nov 08, 2022 - 17:04 UTC
Monitoring
The service is stable, and we are monitoring the issue. Some customers may have to refresh their browsers before the fix is available. If you are still encountering issues, please reach out to support@productboard.com. Thank you for bearing with us.
Posted Nov 08, 2022 - 16:32 UTC
Update
The issue has been identified. We hope to get things back to normal as soon as possible. We apologise for the trouble and thank you for your patience while the issue is being resolved.
Posted Nov 08, 2022 - 16:05 UTC
Identified
We are experiencing an issue that is stopping Productboard from connecting and syncing. We're currently investigating the issue and will provide a status update once we have more information. Apologies for the inconvenience.
Posted Nov 08, 2022 - 15:23 UTC