Productboard doesn't load or shows errors

Incident Report for Productboard

Resolved

Productboard is fully operational now.
Posted Apr 14, 2026 - 13:28 UTC

Update

Productboard currently may take longer to load. We're investigating it and will update you here as we have further details.
Posted Apr 14, 2026 - 12:54 UTC

Investigating

Productboard may not load any page or show errors on some elements. We're currently investigating it and we'll be updating you as we have further details.
Posted Apr 14, 2026 - 12:32 UTC
This incident affected: Web application (Boards and data, Teamspaces, Insights and AI) and Public roadmaps, Public portals.