Potential degradation and issues due to AWS outage

Incident Report for Productboard

Resolved

Following yesterday's AWS outage, mitigation is complete: our third-party providers report services are back to normal and we're observing healthy system performance. We'll continue to monitor closely and update this page if anything changes.
Posted Oct 21, 2025 - 09:50 UTC

Investigating

Due to the AWS incident this morning, we are still experiencing issues. There will be some lags and delays in processing events in the workspace. Our team are monitoring our platform and are ensuring that everything is working smoothly.
Posted Oct 20, 2025 - 14:17 UTC
This incident affected: Web application (Boards and data, Insights and AI).