Productboard is down

Incident Report for Productboard

Resolved

This incident has now been resolved.
Posted Jan 29, 2026 - 16:14 UTC

Update

We are continuing to investigate this issue.
Posted Jan 29, 2026 - 16:13 UTC

Investigating

We are currently investigating this issue and will inform you here on our status page on our progress.
Posted Jan 29, 2026 - 16:11 UTC
This incident affected: Web application (Boards and data, Teamspaces, Insights and AI, Identity and access).