Productboard Service Degradation

Incident Report for Productboard

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 09:12 UTC

Investigating

Application is experiencing loading errors due to an upstream outage of Cloudflare.
Posted Dec 05, 2025 - 08:49 UTC
This incident affected: Website (www.productboard.com).