This incident has been resolved. Filtering on Boards is now fully available and functioning as expected. Thank you for your patience while we worked to resolve this issue.
Posted Apr 22, 2026 - 20:15 UTC
Monitoring
A fix has been applied, and we are currently monitoring the results. Filtering on Boards should now be available.
Posted Apr 22, 2026 - 20:07 UTC
Update
We are continuing to investigate the issue affecting board filtering. Our team is actively working on a resolution and will share further updates as soon as they are available.
Posted Apr 22, 2026 - 19:52 UTC
Investigating
Filtering on Boards is currently unavailable. Users are unable to add new filters or adjust existing ones. We are aware of the issue and are actively investigating. We will provide updates as more information becomes available. We apologize for the inconvenience.
Posted Apr 22, 2026 - 19:19 UTC
This incident affected: Web application (Boards and data).