We are currently experiencing some technical issues and you may be experiencing issues as a result. We apologise for any inconveniences caused and are working resolving the issue
Incident Report for productboard
Resolved
This incident has been fully resolved!
Posted Sep 24, 2020 - 07:00 UTC
Monitoring
A rollback has been deployed and we are monitoring the performance.
Posted Sep 23, 2020 - 18:10 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 23, 2020 - 16:53 UTC
Investigating
We are currently investigating this issue.
Posted Sep 23, 2020 - 16:12 UTC
This incident affected: Web application.