Somethings not working message - Productboard is down

Incident Report for Productboard

Resolved

We have mitigated this incident.

We are so sorry for the inconvenience caused, and we appreciate your understanding and patience during this time.
Posted Nov 06, 2023 - 10:06 UTC

Investigating

Oops something's gone wrong message. We are investigating the issue that Productboard is down. We will update the status page as soon as we have an update.

We apologised for the inconvenience caused.
Posted Nov 06, 2023 - 09:53 UTC
This incident affected: Web application.