Unable to create new feature and roadmap views
Incident Report for Productboard
Resolved
We have resolved the issue by deploying a hot fix. Thank you for your patience while we worked on this issue.
Posted Jun 13, 2024 - 10:51 UTC
Investigating
We are currently investigating an issue where users are unable to create new feature and roadmap views. We apologize for the inconvenience caused. We will share updates on this page as they become available.
Posted Jun 13, 2024 - 10:19 UTC
This incident affected: Web application.